IMG_20140925_194510Ich habe mir kürzlich das Fire TV (Partnerlink) von Amazon gegönnt. Als langjähriger Amazon Prime Kunde und Kunde der früheren Amazon Tochter Lovefilm (beides fusionierte vor einigen Monaten zu Amazon Instant Prime Video) habe ich mit meiner Prime-Mitgliedschaft Zugriff auf unzählige Serien und Filme. Bisher habe ich meine lokalen Filme und Serien über den kleinen Raspberry Pi (siehe auch die Teile 1-5 dieser Artikelserie) gestreamt, leider konnte dieser aber nicht auf Prime Video zugreifen (weil Amazon das nicht will!). Als dann das Angebot kam, den Fire TV für die Hälfte des normalen Preises vorbestellen zu können, habe ich nicht lange gezögert.

Das Gerät ist schnell installiert, einfach mit Fernseher, Soundanlage, dem Internet (LAN oder Wifi) und einer Steckdose verbinden und schon geht es los. Nach einem Update der Software empfängt einem ein üblicher Auswahlbildschirm wie ihn auch so viele andere Dienste bieten. Hier hat man sehr schnell Zugriff auf alle Inhalte, die Sprachsuche entpuppte sich schnell als Highlight, funktioniert tadellos.

Einziger Wermutstropfen, lokale Dateien (aus dem Netzwerk und auch von USB) spielt das Fire TV nicht ab. Ein kurzer Blick ins Netz genügt allerdings, hier findet ihr eine schnelle Anleitung wie ihr XBMC auf dem Fire TV betreiben könnt. In meinem Fall hat die Installation und Inbetriebnahme nur 2 Minuten gedauert. APK installieren, Konfigurationsdateien kopieren (advancedsettings.xml und sources.xml), starten und genießen! Da meine Filmdatenbank und die Filme eigentlich auf dem NAS liegen und er Raspberry Pi selbst keine Daten speichern musste, ist der Wechsel auf den Fire TV so schnell, das kann bei anderen Konfigurationen deutlich länger dauern!

Als Zubehör zum Zocken habe ich mir auch gleich noch den passenden Controller (Partnerlink) geholt, erster Eindruck, passt!

Amazon Fire TV

13 Gedanken zu „Amazon Fire TV

  • 17. Dezember 2014 um 19:10
    Permalink

    Hallo Christian,

    ich habe auch den Fire-Tv mit Kodi (ehemals XBMC) und eine NAS, auf welcher Filme sind.
    Wie bekomme ich es hin, dass meine Filmdatenbank auf der NAS gespeichert wird und nicht auf dem Fire-Tv??

    Bemerkung:
    Eine advancedsettings.xml und sources.xml habe ich bisher nirgendwo gesehen. Kodi habe ich mittels abdfire installiert.

    Über eine Antwort wäre ich dankbar!

    Grüße
    Arnold

    Antworten
    • 18. Dezember 2014 um 17:25
      Permalink

      Hallo, wie du bereits richtig geschrieben hast, läuft das dann über die advancedsettings.xml, in der du den Speicherort der Datenbank angibst. Wenn du diese Dateien bereits von einem anderen System hast (wie bei mir der Raspberry Pi) kannst du sie einfach auf den FireTV kopieren (s. hier unter Punkt 7.1). Achtung: Unbedingt die NFS-Freigabebedingungen im NAS überprüfen und um die IP des FireTV erweitern!
      Solltest du noch keine advancedsettings.xml und sources.xml haben, so findest du hier eine mögliche Konfiguration (IPs und Pfade anpassen!).

      Antworten
  • 19. Dezember 2014 um 2:55
    Permalink

    Hallo nochmal,

    ich habe eine advancedsettings.xlm wie folgt erstellt…

    special://profile/Thumbnails/
    smb://meineIP/video/Thumbnails/

    Es wurden in den Thumbnail Ordner nur die Struktur angelegt und Hauptdarsteller und ein paar Covers reinkopiert???

    Wie bekomme ich es hin, dass alle Covers etc. auf die nas kommen?

    (ich benutze eine Zyxel NSA325-V2)

    Antworten
  • 19. Dezember 2014 um 2:56
    Permalink

    So habe ich erstellt: (oben wird nicht alles angezeigt)

    special://profile/Thumbnails/
    smb://meineID/video/Thumbnails/

    Antworten
  • 19. Dezember 2014 um 10:19
    Permalink

    Hallo,

    ich bin´s nochmal.

    Die advancedsettings.xml ist jetzt auf dem Fire TV.
    Den Inahlt der xlm habe ich beispielsweise hier entnommen http://xbmc-blog.de/xbmc-thumbnails-synchronisieren/(mit meiner IP und Pfad).

    Es wurden nach der Einrichtung auch die Unterpfade, wie im Fire Tv auf dem NAS erstellt.

    Aber der Inhalt dieser Verzeichnisse sind nur „Filmdarsteller“ und ein „paar“ Cover.

    Wie bekomme ich es hin, dass die Hintergründe und Poster auch auf den NAS übernommen werden?

    Zudem habe ich das Problem, dass nur die englischen (wahrscheinlich Originaltitel) in der Video – Auswahlliste angezeigt werden, obwohl ich das im Menü nicht aktiviert habe. Meine Verzeichnisse haben die deutschen Titel??

    Kannst Du mir hier noch einen Rat geben?

    DANKE und ein Frohes Fest, guten Rutsch etc.

    Arnold

    Antworten
    • 19. Dezember 2014 um 17:23
      Permalink

      Hallo Arnold, das mit den Covern kann etwas dauern, XBMC lädt die nicht alle auf einmal komplett, sondern immer nur dann, wenn sie benötigt werden. Wenn du dir deine Filmliste in XBMC ansiehst, lädt er nach und nach die Cover nach und legt sie dann ab, bis er irgendwann alle hat. Das kann aber dauern.
      Das Problem der englischen Titel kannst du dadurch lösen, dass du beim Einstellen des verwendeten Scrapers für deinen Filmordner unter Einstellungen die “Bevorzugte Sprache” festlegst. Eine umfangreiche Erläuterung findest du hier.

      Ich hoffe ich konnte helfen, wünsche Dir ein Frohes Fest!

      Antworten
  • 21. Dezember 2014 um 13:33
    Permalink

    Hi nochmal,

    die advancedsettings.xml ist auf dem Fire-TV, die Grundeinstellungen TMDb passen, es werden auf meiner NAS im Verzeichnis Thumbnails Unterverzeichnisse angelegt, in der einige jpg´s drinnen sind.

    Fanart und Poster finde ich keine und im Fire-Tv werden auch keine dargestellt und auch nicht nach und nach geladen!

    Wenn ich die advancedsettings.xlm wieder lösche (und die Daten auf dem Fire-TV liegen) funktioniert wieder alles.

    Fehlt evtl. ein code in meiner advancedsettings.xml??

    _
    _
    _
    _ special://profile/Thumbnails/
    _ smb://nas/xbmc/userdata/Thumbnails/
    _
    _
    _

    Ich bin noch am verzweifeln!

    Was ich gerne hätte, daß die Poster, Fanart, etc. auf meiner NAS gespeichert sind und den Speicher des FIRE TV nicht belegen. Zudem sollte es +- genauso schnell funktionieren. Was würde sonst ein „Auslagern“ Sinn machen!

    Gibt es ein anderes Verzeichnis außer Thumbnails, wo Fanart und Poster gespeichert werden?

    🙁
    Arnold

    Antworten
  • 21. Dezember 2014 um 13:36
    Permalink

    Irgendwie kriege ich hier meine codes der advancedsettings.xml nicht richtig rein.

    Deshalb hier nochmal ohne

    advancedsettings
    pathsubstitution
    substitute
    from>special://profile/Thumbnails/smb://nas/xbmc/userdata/Thumbnails/</to
    /substitute
    /pathsubstitution
    /advancedsettings

    Antworten
    • 22. Dezember 2014 um 17:11
      Permalink

      Bei der Pfadsubstitution genau auf die Syntax achten, hier noch eine Anleitung dazu.
      Zudem würde ich statt SMB lieber NFS nutzen, das ist schneller und bringt weniger Probleme mit Berechtigungen mit sich. Bei mir läuft die Pfadsubstitution mit NFS sehr zuverlässig.

      Antworten
  • 14. Januar 2015 um 17:37
    Permalink

    Hi Experten,

    ich habe ein anderes Problem. Meine Aufnahmen kommen von einem Vu+ Duo Sat-Receiver. Die Dateien haben folgenden Format:

    20150113 19:00 – ZDF HD – James Bond.ts

    Was muss ich machen damit auch für solche Aufnahmen/Filme Infos geholt werden?

    Antworten
    • 15. Januar 2015 um 15:58
      Permalink

      Hallo Chris, ein Umbenennen der Datei sollte ausreichen. Der Scrapper, also das Programm das versucht dem Dateinamen einen Filmtitel zuzuordnen, dürfte es bei dir mit den aktuellen Titeln sehr schwer haben. Du müsstest die Dateinamen editieren. Z.B. aus 20150113 19:00 – ZDF HD – James Bond.ts sowas hier machen „James Bond – Casino Royal.ts“.

      Antworten
  • 4. März 2015 um 13:45
    Permalink

    Hallo Christian,

    in der Zwischenzeit habe ich es herausgefunden, dass ich die tmdb.xml modifizieren muss (Kodi 14.1). Ich will die Dateien nicht umbenennen und die Namen in dem Scraper zu ändern ist mir bis heute noch nicht gelungen. In dem wird die URL mit den Filmnamen zusammen gestellt. Man muss also vorher den Input $1 entsprechend ändern. Habe folgendes gebastelt:

    d{8}.d{4}(.-.)[^-]*(..)$
    aber es klappt nicht. Erkannt jemand vielleicht wo mein Fehler liegt?

    Chris

    Antworten
    • 2. April 2015 um 11:17
      Permalink

      Hallo Chris, hat etwas gedauert, habe mir das aber mal angesehen und hier getestet. Folgender Ausdruck scheint zu funktionieren: ^d{8}sd{2}[:]d{2}s[ –]s

      Grüße,
      Christian

      Edit: Achtung, damit der Ausdruck funktioniert muss dein verwendeter Bindestrich eingefügt werden ([ –]), fügst du dort ein normales Minus ein, funktioniert der Ausdruck nicht!

      Antworten

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.